<!DOCTYPE html>
<!--[if lte IE 8]>         <html lang="en-US" class="lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
	<meta charset="utf-8">
	
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"b5b353e6a9","applicationID":"249497229,129121101","transactionName":"cwkPEUdWCV5RFB9DUlcDEkpdWAtWWANvQF9FAQ==","queueTime":6,"applicationTime":313,"agent":""}</script>
<script>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</script>
	<title>2020-2021 Budget  - Mamaroneck Union Free School District</title>
		<link rel="icon" href="/uploaded/favicon.ico">
	<meta name="description" content="2020-2021 Budget  - Mamaroneck Union Free School District">
	<meta name="keywords" content="2020-2021 Budget , Mamaroneck Union Free School District">
	<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
		
			<link rel="canonical" href="https://www.mamkschools.org/district/board-of-education/2020-2021-budget">
			<meta property="og:url" content="https://www.mamkschools.org/district/board-of-education/2020-2021-budget">
		<meta property="og:description" content="2020-2021 Budget  - Mamaroneck Union Free School District">



	<meta property="og:title" content="2020-2021 Budget  - Mamaroneck Union Free School District">
	<meta property="og:type" content="website">

	<link rel="stylesheet" media="all" href="/assets/application-18a62c94c335f6aa615269970bd0e52b265fe082c4d83f534087fff771c5edec.css" />

	

	<!-- CF Styles Manager -->
	<link href="/styles.cfm?b" media="screen" rel="stylesheet">

		<link rel="stylesheet" media="all" href="/uploaded/themes/default/css/main.css?1572024884" />

		<script src="/assets/in_layout_head-c5c1dced2f97189dfe1a1275283001b64f0ee9657938ce5013cc89d6a554d65e.js"></script>

		<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css">
		

	<script type="text/javascript">
		(function(window) {
			window.FS.currentPage = {
				dateFormat: 'md',
				timeFormat: '12'
			};
		})(window);
	</script>

	
</head>
<body data-logged-in="false" data-pageid="1568" class="fsLiveMode fsHasHeader fsHasRightBanner fsHasFooter fsHasOneColumnLayout fsSection289 fsHasTheme10">

		<script>
			dataLayer = [{ 'schoolDomain': 'www.mamkschools.org' }];
				dataLayer.push({'uaID': 'UA-81435146-1' });

		</script>

			<noscript>
				<iframe src="//www.googletagmanager.com/ns.html?id=GTM-P3BGC7"
					height="0" width="0" style="display:none;visibility:hidden">
				</iframe>
			</noscript>
			<script>
      (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
          j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
          '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-P3BGC7');
			</script>


<div id="fsPageWrapper">




			<a id="fsSkipToMainContentLink" class="fsStateHidden" href="#fsPageContent">Skip To Main Content</a>
			<header id="fsHeader" class="fsHeader">
				<div class=" fsBanner fsStyleAutoclear" id="fsEl_8593" >

			<div class="fsElement fsContainer nav-container" id="fsEl_8594" data-use-new="true" >

				<header>
			<div class="fsElementHeaderContent">
				<div class="mobile-trigger"></div>
			</div>
	</header>
	<div class="fsElementContent" >
			<div class="fsElement fsContainer nav-util-container" id="fsEl_8595" data-use-new="true" >

				<div class="fsElementContent" >
			<div class="fsElement fsNavigation fsList nav-util" id="fsEl_8596" data-use-new="true" >

				<div class="fsElementContent" >
		<nav><ul class="fsNavLevel1"><li class="fsNavParentPage"><a href="http://#quicklink">Tools</a><div class="fsNavPageInfo"><ul class="fsNavLevel2"><li><a href="/dashboard/staff">Staff</a></li><li><a href="/dashboard/student">Student</a></li><li><a href="/dashboard/parent">Parent</a></li></ul></div></li><li><a href="http://www.facebook.com/MamaroneckPublicSchools" target="_blank">Facebook</a></li><li><a href="https://www.instagram.com/mamaroneck_public_schools/" target="_blank">Instagram</a></li><li><a href="https://www.youtube.com/channel/UC8dhzb2xa51BqkwbB15JdAA" target="_blank">Youtube</a></li><li><a href="http://twitter.com/MamaroneckED" target="_blank">Twitter</a></li><li class="search"><a href="http://#search">Search</a></li></ul></nav>
	</div>


	</div>
	<div class="fsElement fsContent translate-container" id="fsEl_8597" data-use-new="true" >

				<div class="fsElementContent" >
			<div class="google-translate-toggle">Translate</div>
<div id="google_translate_element"></div><script type="text/javascript">function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en'}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>

	</div>


	</div>
	<div class="fsElement fsSearch top-search fsSearchField" id="fsEl_8617" data-use-new="true" data-api-key="ZTJlOWFiNTdmMjA0MzhkN2ZmMjA5ODM5YTQxMDgwZmE5YWEwOTVlYzhlM2ZiOTM1OTU2MTg1NmY1OTI2YmZmMnJlc3RyaWN0U2VhcmNoYWJsZUF0dHJpYnV0ZXM9JTVCJTIyY29udGVudCUyMiUyQyUyMnRpdGxlJTIyJTVEJmZpbHRlcnM9ZG9tYWluX2lkKyUzRCs3ODYrQU5EKyUyOE5PVCtwdWJsaWMlM0FmYWxzZSUyOSZ2YWxpZFVudGlsPTE1ODg5MzM1MzcmcmVzdHJpY3RJbmRpY2VzPW1hbWtzY2hvb2xzb3JnX3BhZ2Vz" data-app-id="94N15DCPDQ" data-index="mamkschoolsorg_pages" >

				<div class="fsElementContent" >
		


<div class="fsCustomSearch">

		<div class="gsc-control-searchbox-only gsc-control-searchbox-only-en" dir="ltr">

			<form class="gsc-search-box gsc-search-box-tools" accept-charset="utf-8" action="/search/search-landing-page">

				<table cellspacing="0" cellpadding="0" class="gsc-search-box">
					<tbody>
					<tr>
						<td class="gsc-input">
							<div class="gsc-input-box">
								<table cellspacing="0" cellpadding="0" style="width: 100%; padding: 0px;">
									<tbody>
									<tr>
										<td class="gsib_a">
											<input autocomplete="off" type="text" size="10" class="gsc-input" name="q" title="search" dir="ltr" spellcheck="false" style="width: 100%; padding: 0px; border: none; margin: -0.0625em 0px 0px; height: 1.25em; outline: none;">
										</td>
										<td class="gsib_b">
											<div class="gsst_b" dir="ltr"><a class="gsst_a" href="javascript:void(0)"><span class="gscb_a">×</span></a></div>
										</td>
									</tr>
									</tbody>
								</table>
							</div>
						</td>
						<td class="gsc-search-button">
							<input alt="Submit Search" type="image" src="/assets/icons/frontend/google_search_box_icon-76a0d76f135419f4d00213037cda0cba949a0372e01ab6a1d70072008a56bd18.png" title="search" class="gsc-search-button gsc-search-button-v2" />
						</td>
						<td class="gsc-clear-button">
							<div class="gsc-clear-button" title="clear results">&nbsp;</div>
						</td>
					</tr>
					</tbody>
				</table>

				<table cellspacing="0" cellpadding="0" class="gsc-branding"></table>

			</form>


		</div>

</div>


	</div>


	</div>



	</div>


	</div>
	<div class="fsElement fsContent site-info-container" id="fsEl_8598" data-use-new="true" >

				<div class="fsElementContent" >
			<h1><a href="/"><img width="399" src="/uploaded/themes/default/images/logo-simple.png">Mamaroneck Schools</a></h1>

	</div>


	</div>
	<div class="fsElement fsNavigation fsList nav-main" id="fsEl_8599" data-use-new="true" >

				<div class="fsElementContent" >
		<nav><ul class="fsNavLevel1"><li class="fsNavParentPage fsNavCurrentPageAncestor"><a href="/district/about-us">District</a><div class="fsNavPageInfo"><ul class="fsNavLevel2"><li><a href="/district/about-us">About Us</a></li><li class="fsNavCurrentPageAncestor"><a href="/district/board-of-education">Board of Education</a></li><li><a href="/district/business-office">Business Office</a></li><li><a href="/district/directory">District Directory</a></li><li><a href="/district/enrollment-planning">Enrollment Task Force</a></li><li><a href="/district/personnel">Human Resources</a></li><li><a href="/district/news">News</a></li></ul></div></li><li class="fsNavParentPage"><a href="/teaching-learning">Teaching &amp; Learning</a><div class="fsNavPageInfo"><ul class="fsNavLevel2"><li><a href="/teaching-learning">Curriculum &amp; Instruction</a></li><li><a href="/teaching-learning/dual-language-program">Dual Language Program</a></li><li><a href="/teaching-learning/technology">Educational Technology</a></li><li><a href="/teaching-learning/elementary-curriculum">Elementary Learning</a></li><li><a href="/schools/hommocks-middle-school/hommocks-departments" target="_blank">Middle School Learning</a></li><li><a href="/schools/mamaroneck-high-school/mamaroneck-high-school-departments" target="_blank">High School Learning</a></li><li><a href="/teaching-learning/social-emotional-learning">Mindfulness/ SEL</a></li><li><a href="/teaching-learning/response-to-intervention">Response to Intervention</a></li><li><a href="/teaching-learning/student-support-services">Student Support Services</a></li><li><a href="/teaching-learning/sustainability">Sustainability</a></li></ul></div></li><li class="fsNavParentPage"><a href="/schools">Schools</a><div class="fsNavPageInfo"><ul class="fsNavLevel2"><li><a href="/schools/mamaroneck-high-school">Mamaroneck High School</a></li><li><a href="/schools/hommocks-middle-school">Hommocks Middle School</a></li><li><a href="/schools/central-school">Central School</a></li><li><a href="/schools/chatsworth-avenue-school">Chatsworth Ave School</a></li><li><a href="/schools/mamaroneck-avenue-school">Mamaroneck Ave School</a></li><li><a href="/schools/murray-avenue-school">Murray Ave School</a></li></ul></div></li><li class="fsNavParentPage"><a href="/parents-community">Community</a><div class="fsNavPageInfo"><ul class="fsNavLevel2"><li><a href="/parents-community/athletics">Athletics</a></li><li><a href="/parents-community/community-partners">Community Partners</a></li><li><a href="/parents-community/emergency-management-plan">Emergency Management </a></li><li><a href="/parents-community/enotify-archive">Enotify Archive</a></li><li><a href="/parents-community/facilities">Facilities</a></li><li><a href="/parents-community/food-services">Food Services</a></li><li><a href="/parents-community/student-health-services">Health Services</a></li><li><a href="http://www.mamaroneckschoolsfoundation.org/mamaroneck-alumni-assoc" target="_blank">Mamaroneck Alumni</a></li><li><a href="/dashboard/parent">Parent Tools</a></li><li><a href="http://mamkschoolspta.org/PTCouncil/" target="_blank">PTA</a></li><li><a href="/dashboard/parent/registration">Registration</a></li><li><a href="http://mamkschoolspta.org/septa/" target="_blank">SEPTA</a></li><li><a href="/parents-community/theatermusic-performances-schedule">Theater/Concert Schedule</a></li><li><a href="/parents-community/transportation">Transportation</a></li><li><a href="/parents-community/health-and-wellness">Wellness Committee</a></li></ul></div></li></ul></nav>
	</div>


	</div>



	</div>


	</div>
	<div class="fsElement fsContent" id="fsEl_8601" data-use-new="true" >

				<div class="fsElementContent" >
			<img alt="Cupola Photo" src="/uploaded/photos/cupola_with_tree.jpg" width="1900">

	</div>


	</div>
	<div class="fsElement fsNavigation fsBreadcrumb site-info-container" id="fsEl_13160" data-use-new="true" >

				<div class="fsElementContent" >
		<nav aria-label="breadcrumbs">
    <ul>
        <li  >
		<a href="/">Home</a> <span aria-hidden="true" class="fsNavBreadcrumbSeperator">&gt;</span>
</li>
<li  >
		<a href="/district/about-us">District</a> <span aria-hidden="true" class="fsNavBreadcrumbSeperator">&gt;</span>
</li>
<li  >
		<a href="/district/board-of-education">Board of Education</a> <span aria-hidden="true" class="fsNavBreadcrumbSeperator">&gt;</span>
</li>
<li aria-current=location >
			2020-2021 Budget 
</li>

    </ul>
</nav>

	</div>


	</div>



</div>


			</header>

		<div id="fsPageBodyWrapper" class="fsPageBodyWrapper">
			<div id="fsPageBody" class="fsStyleAutoclear fsPageBody">

				<main id="fsPageContent" class="fsPageContent">
							<h1 class="fsPageTitle">2020-2021 Budget </h1>




							<div class="fsPageLayout fsLayout fsOneColumnLayout fsStyleAutoclear" id="fsEl_17702" data-use-new="true" >

				<div class=" fsDiv fsStyleAutoclear" id="fsEl_17703"  >

				<div class="fsElement fsContent" id="fsEl_18551" data-use-new="true" >

				<div class="fsElementContent" >
			<p>In accordance with Executive Order 202.26, the school district budget vote and election of trustees has been adjourned to June 9, 2020 and will be held remotely only by absentee ballot. Absentee ballots are cast by a qualified voter who is unable to attend the official polling station to which the voter is normally allocated. <strong>Absentee ballots -- which will be mailed by the school district to all qualified voters, together with a postage paid return envelope -- are due back by 5 pm on Tuesday, June 9.</strong></p>

<p>In order to qualify to vote you must be at least 18 years of age, a U.S. citizen, resident of the district for 30 days immediately preceding the election and a registered voter.</p>

<p>If you are not registered, prospective voters can still register to vote with the local county board of elections by completing an online application with the New York State Department of Motor Vehicles at https://dmv.ny.gov/more-info/electronic-voterregistration-application.</p>


	</div>


	</div>
	<div class="fsElement fsPanelGroup fsAccordion fsPanelIconBefore" id="fsEl_17706" data-use-new="true" >

				<div class="fsElementContent" >
		<ul class="fsTabsNav" role="tablist">
    <li id="fsTab-18552" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18552">May 5, 2020 Budget Presentation </a>
			
        </li><li id="fsTab-18451" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18451">April 21, 2020 Budget Presentation </a>
			
        </li><li id="fsTab-18415" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18415">April 14, 2020 Budget Presentation</a>
			
        </li><li id="fsTab-18301" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18301">March 31, 2020: Revised Budget Presentation (w/$1,122,630 in proposed reductions)</a>
			
        </li><li id="fsTab-18303" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18303">Press Release: 2020-2021 Superintendent's Recommended Budget/Education Plan Presented</a>
			
        </li><li id="fsTab-17731" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17731">Superintendent's Recommended Budget </a>
			
        </li><li id="fsTab-17707" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17707">2020-2021 Budget Planning Calendar</a>
			
        </li><li id="fsTab-17709" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17709">Budget Presentations </a>
			
        </li><li id="fsTab-17723" class="fsTabsNavItem" role="presentation">
			<a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17723">Voter Information</a>
			
        </li>

</ul>

	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_18552" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18552">May 5, 2020 Budget Presentation </a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-18552"></a>
	<div class="fsElement fsContent" id="fsEl_18553" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://www.mamkschools.org/uploaded/Communications/2020-2021_Budget/May_5,_2020_Budget_Presentation.pdf?1588791505003" target="_blank">Presentation of Budget Up for Adoption</a><br />
(The Board adopted the budget, which now becomes the &quot;Proposed Budget&quot; that the community will vote on by absentee ballot only June 9, 2020.)</p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_18451" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18451">April 21, 2020 Budget Presentation </a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-18451"></a>
	<div class="fsElement fsContent" id="fsEl_18452" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://www.mamkschools.org/uploaded/Communications/2020-2021_Budget/April_21,_2020_Supertintendent's_Recommended_Budget_Presentaton.pdf?1587577031037" target="_blank">Continued Budget Discussion: April 21, 2020</a></p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_18415" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18415">April 14, 2020 Budget Presentation</a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-18415"></a>
	<div class="fsElement fsContent" id="fsEl_18416" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://mamkschoolsorg.finalsite.com/uploaded/Communications/Budget/2020-2021_Budget/April_14,_2020_Budget_Presentation.pdf?1586911886551" target="_blank">See presentation here</a></p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_18301" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18301">March 31, 2020: Revised Budget Presentation (w/$1,122,630 in proposed reductions)</a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-18301"></a>
	<div class="fsElement fsContent" id="fsEl_18302" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://mamkschoolsorg.finalsite.com/uploaded/Communications/Budget/2020-2021_Budget/March_31_budget_presentaion.pdf?1585752678757" target="_blank">See PowerPoint Here</a></p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_18303" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-18303">Press Release: 2020-2021 Superintendent's Recommended Budget/Education Plan Presented</a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-18303"></a>
	<div class="fsElement fsContent" id="fsEl_18304" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://mamkschoolsorg.finalsite.com/cf_enotify/view.cfm?n=541" target="_blank">Read Press Release Here</a></p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_17731" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17731">Superintendent's Recommended Budget </a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-17731"></a>
	<div class="fsElement fsContent" id="fsEl_17732" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://www.mamkschools.org/uploaded/Communications/2020-2021_Budget/Supt._Recommended_Budget_-_2020-2021.pdf?1583334864100" target="_blank">View the 2020-2021 Superintendent&#39;s Recommended Budget in its entirety here.</a></p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_17707" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17707">2020-2021 Budget Planning Calendar</a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-17707"></a>
	<div class="fsElement fsContent" id="fsEl_17708" data-use-new="true" >

				<div class="fsElementContent" >
			<p><strong>Due to the Coronavirus, the budget planning calendar is being revised. The annual budget election for all districts throughout New York has been delayed by the Governor&#39;s Executive Order to June 1 or beyond.&nbsp;</strong>&nbsp; <a href="https://www.mamkschools.org/uploaded/Communications/2020-2021_Budget/2020-21_Budget_Planning_Calendar_rev_2.pdf?1578603216742" target="_blank">See original budget planning calendar here</a>.</p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_17709" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17709">Budget Presentations </a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-17709"></a>
	<div class="fsElement fsContent" id="fsEl_17710" data-use-new="true" >

				<div class="fsElementContent" >
			<p><a href="https://mamkschoolsorg.finalsite.com/uploaded/Communications/Budget/2020-2021_Budget/April_14,_2020_Budget_Presentation.pdf?1586911886551" target="_blank">Further Reductions Presented/Continued Discussion of Superintendent&#39;s Recommended Budget </a>- April 14, 2020<br />
<a href="https://mamkschoolsorg.finalsite.com/uploaded/Communications/Budget/2020-2021_Budget/March_31_budget_presentaion.pdf?1586912282138" target="_blank">Presentation Proposing $1.1 Million in Reductions</a> - March 31, 2020<br />
<a href="https://www.mamkschools.org/uploaded/Communications/2020-2021_Budget/Superintendent's_Recommended_Budget_presentation_-_March_3,_2020.pdf?1583334518675" target="_blank">2020-2021 Superintendent&#39;s Recommended Budget</a> - March 3, 2020 PowerPoint<br />
<a href="https://www.mamkschools.org/uploaded/Communications/Board_of_Education/'19-'20_BOE/Feb._11,_2020_Budget_Update_PowerPoint.pdf?1581601525207" target="_blank">Budget Development Update</a> - Feb. 11, 2020<br />
The 2020-2021 Superintendent&#39;s Recommended Budget will be presented at the Board of Education meeting on March 3, 2020 - 7 pm,&nbsp;Mamaroneck High School&nbsp;Tiered Classroom.&nbsp;</p>

<p>&nbsp;</p>


	</div>


	</div>



	</div>


	</section>
	<section class="fsElement fsPanel fsStyleAutoclear" id="fsEl_17723" data-use-new="true" role="tabpanel" >

				<header>
			<h2 class="fsElementTitle"><a role="tab" aria-selected="false" aria-expanded="false" href="#fs-panel-17723">Voter Information</a></h2>
	</header>
	<div class="fsElementContent" aria-hidden="true">
		<a id="fs-panel-17723"></a>
	<div class="fsElement fsContent" id="fsEl_17724" data-use-new="true" >

				<div class="fsElementContent" >
			<p><span class="fs_style_22">THE ANNUAL BUDGET ELECTION FOR ALL DISTRICTS THROUGHOUT NEW YORK HAS BEEN DELAYED BY THE GOVERNOR&#39;S EXECUTIVE ORDER TO JUNE 9, 2020.&nbsp; THE COMMUNITY VOTE WILL BE CONDUCTED <u>EXCLUSIVELY BY ABSENTEE BALLOT</u>. </span></p>

<p><b><i>Registering to Vote</i></b></p>

<p><i>During the current mandated school district closure and need for social isolation, personal voter registration may not take place in school districts.&nbsp; Qualified Voters may register to vote with the local County Board of Elections by completing an online application with the New York State Department of Motor Vehicles at&nbsp;</i><b id="docs-internal-guid-5b6d214e-7fff-d280-bd4f-363a42887ede">https://dmv.ny.gov/more-info/electronic-voterregistration-application</b></p>

<p><b><i>Qualified Voter</i></b></p>

<p><i>A qualified voter must be 18 years old by June 9, 2020, a citizen of the United States and a resident within the Mamaroneck School District&nbsp;for 30 days immediately preceding the vote, and not otherwise prohibited from voting.</i></p>

<p><b><i>Vote by Absentee Ballot</i></b></p>

<p dir="ltr"><b id="docs-internal-guid-ecb82a4e-7fff-87d4-ca16-e428688e4b3d">Absentee ballots will be mailed by the school district to all qualified voters, together with a postage paid return envelope. If there is a member of your household who is a qualified voter and did not receive an absentee ballot, please notify the District Clerk at jrice@mamkschools.org and a ballot will be sent out.</b></p>


	</div>


	</div>



	</div>


	</section>




	</div>


	</div>
	<div class="fsElement fsContent" id="fsEl_17704" data-use-new="true" >

				<div class="fsElementContent" >
			

	</div>


	</div>




	</div>




	</div>



				</main>
					<div id="fsBannerRight" class="fsBannerRight">
						<div class=" fsBanner fsStyleAutoclear" id="fsEl_7626" >

			<div class="fsElement fsContainer" id="fsEl_8483" data-use-new="true" >

				<div class="fsElementContent" >
		


	</div>


	</div>
	<div class="fsElement fsNavigation fsList nav-sub" id="fsEl_7627" data-use-new="true" >

				<div class="fsElementContent" >
		<nav><ul class="fsNavLevel1"><li><a href="/district/about-us">About Us</a></li><li class="fsNavParentPage fsNavCurrentPageAncestor"><a href="/district/board-of-education">Board of Education</a><div class="fsNavPageInfo"><ul class="fsNavLevel2"><li><a href="/district/board-of-education/questions-from-the-community">Board/Superintendent's Inbox</a></li><li><a href="http://www.boarddocs.com/ny/mufsd/Board.nsf/Public" target="_blank">Board Docs</a></li><li><a href="/district/board-of-education/2019-2020-budget">2019-2020 Budget </a></li><li class="fsNavCurrentPage"><a href="/district/board-of-education/2020-2021-budget">2020-2021 Budget </a></li><li><a href="/district/board-of-education/15-16-committee-notes">Committee Notes</a></li><li><a href="/district/board-of-education/meetings">Meeting Notices &amp; Schedule</a></li><li><a href="http://www.mamkschools.org/uploaded/District_Files/Board_of_Education/2016-2017_Board_operating_Procedures_rev_11-18-16.doc" target="_blank">Operating Procedures</a></li><li><a href="/district/board-of-education/policies">Policies</a></li><li><a href="/district/board-of-education/15-16-presentations">Presentations</a></li></ul></div></li><li><a href="/district/business-office">Business Office</a></li><li><a href="/district/directory">District Directory</a></li><li><a href="/district/enrollment-planning">Enrollment Task Force</a></li><li><a href="/district/personnel">Human Resources</a></li><li><a href="/district/news">News</a></li></ul></nav>
	</div>


	</div>



</div>


					</div>
			</div>
		</div>

			<footer id="fsFooter" class="fsFooter">
				<div class=" fsBanner fsStyleAutoclear" id="fsEl_1528" >

			<div class="fsElement fsContainer school-info" id="fsEl_7287" data-use-new="true" >

				<div class="fsElementContent" >
			<div class="fsElement fsContent footer-address" id="fsEl_7288" data-use-new="true" >

				<div class="fsElementContent" >
			<ul>
  <li><h5>Mamaroneck Union Free School District</h5></li>
  <li>1000 West Boston Post Road</li>
  <li>Mamaroneck, NY 10543 </li>
  <li>914-220-3000</li>
  <li><a href="/fs/pages/265" title="Contact Numbers and Addresses" target="_blank">Contact Us</a> | <a href="/fs/pages/264" target="_blank" title="Driving Directions" data-page-name="Map &amp; Directions">Driving Directions</a></li><li><a href="/fs/pages/268" target="_blank" title="District Privacy Policy" data-page-name="Privacy Policy">Privacy Policy</a> | <a href="/fs/pages/727" title="Accessibility Information Page" data-page-name="Accessibility">Accessibility</a></li><p></p></ul>

	</div>


	</div>
	<div class="fsElement fsContent footer-social" id="fsEl_7289" data-use-new="true" >

				<div class="fsElementContent" >
			<ul>
  <li><a href="http://www.facebook.com/MamaroneckPublicSchools" class="fb" target="_blank">Facebook</a></li>
  <li><a href="http://twitter.com/MamaroneckED" class="tw" target="_blank">Twitter</a>
</li>
  <li><a href="https://www.youtube.com/channel/UC8dhzb2xa51BqkwbB15JdAA" class="yt" target="_blank" >YouTube</a>
</li>
  <li><a href="https://www.instagram.com/mamaroneck_public_schools/" class="ig" target="_blank">Instagram</a></li>
</ul>

	</div>


	</div>



	</div>


	</div>
	<div class="fsElement fsNavigation fsList nav-footer" id="fsEl_7290" data-use-new="true" >

				<div class="fsElementContent" >
		<nav><ul class="fsNavLevel1"><li><a href="/calendar/all-district-calendar" target="_blank">District Calendar</a></li><li><a href="/district/news" target="_blank">District News</a></li><li><a href="/schools">District Schools</a></li><li><a href="/dashboard/staff" target="_blank">Staff Tools</a></li><li><a href="/dashboard/student/elementary-dashboard" target="_blank">Elementary Tools</a></li><li><a href="/dashboard/student/middle-school-dashboard" target="_blank">Hommocks Tools</a></li><li><a href="/dashboard/student/high-school-dashboard" target="_blank">High School Tools</a></li><li><a href="/dashboard/parent">Parent Tools</a></li></ul></nav>
	</div>


	</div>
	<div class="fsElement fsContent footer-mission" id="fsEl_7291" data-use-new="true" >

				<div class="fsElementContent" >
			<h5>Our Mission</h5>

<p>It is the mission of the Mamaroneck Union Free School District to promote intellectual engagement and an appreciation of learning as an inherently rewarding activity and to prepare students to function as responsible citizens in a multicultural world.</p>

<p>&nbsp;</p>


	</div>


	</div>




</div>


			</footer>

				<div id="fsPoweredByFinalsite" role="complementary">
		<div>
			<a href="https://www.finalsite.com/district" title="Powered by Finalsite opens in a new window" target="_blank">Powered by Finalsite</a>
		</div>
	</div>



</div>


	<div id="fsPagePopCollection" hidden>
			<article class="fsPagePop" data-delay-option="" data-delay-time="" data-id="433" data-reset-at="" data-visible-at="2020-05-04T05:00:00Z">
				<h2 class="fsPagePopTitle">Update: Community Budget Election Set for June 9 by Absentee Ballot Only</h2>
				<div class="fsPagePopMessage">
					<p>Due to the Coronavirus update, the annual school budget election for all districts throughout NY has been delayed by Gov. Cuomo&#39;s Executive Order&nbsp;to June 9, 2020. The community budget vote will be conducted exclusively by absentee ballot. Stay tuned for more info.</p>

				</div>
			</article>
	</div>



<script src="/assets/application-d7d17adc46bc545b59a52c5c1dfd45f825117797ff8a4f8b5a184b91797e5c75.js"></script>

	<script src="/uploaded/themes/default/js/main.js?1572024884"></script>






<script>
	if (typeof newrelic == 'object') {
		newrelic.setCustomAttribute('tenant', 'mamkschoolsorg');
	}
</script>
</body></html>
